We have been monitoring the issue and our upstream provider has resolved the issue.
Posted Jun 11, 2025 - 09:31 EDT
Update
Company & Location merging appears to be working again and we are currently monitoring the upstream provider issue. All other systems and features are up and running at this time. We will be monitoring and posting here progress as we receive information from our provider. Here is a link with additional details from our upstream provider:
Company & Location merging is currently not available due to an upstream provider issue. All other systems and features are up and running at this time. We will be monitoring and posting here progress as we receive information from our provider.
Posted Jun 10, 2025 - 11:02 EDT
This incident affected: Upstream Providers (Heroku Platform for AutoElevate) and AutoElevate (Admin Portal).