AutoElevate Agent with Blocker Enabled System Instability Due to Windows Update

Incident Report for CyberFOX

Resolved

Rollout complete, issue resolved. Please make sure that your deployment scripts are not pointing to any specific older versions of the installer. If you do mistakenly install an older version, use the "Update" action in the Admin Portal Computers grid to update those agents to the latest version.
Posted Aug 22, 2025 - 08:49 EDT

Monitoring

The fix build (v2.10.24) is now being rolled out in GA to all partners. Please see the following article for more information: https://roadmap.cyberfox.com/changelog/windows-agent-v21024-ga-rollout-begins-august-12th

We will continue to monitor and be alert to any issues throughout the rollout process.
Posted Aug 14, 2025 - 08:56 EDT

Update

We have released a new version of the AutoElevate agent (v2.10.23.0) to internal systems on July 30th, and to all clients with open tickets who were previously testing v2.10.20.0 on July 31st. So far, we have not experienced any system freezes internally, and we have not received any new reports of freezing from clients testing the latest version.

If this trend continues through Wednesday, August 7th, we plan to begin a full rollout to all customers starting Tuesday, August 12th.

If you would like to test v2.10.23.0 in your own environment, you can download it here:

👉 Download v2.10.23.0 Agent: https://autoelevate-installers.s3.us-east-2.amazonaws.com/versions/AESetup-2.10.23.0.msi

Alternatively, if you'd like us to auto-update your agents, please contact us at support@cyberfox.com.
Posted Aug 04, 2025 - 20:14 EDT

Update

We have identified a potential issue between the AutoElevate blocker agent and the recent Windows updates. We have a new agent with additional updates for a possible resolution. If you would like to test the latest version of the agent, please contact us at support@cyberfox.com. Once we confirm the resolution with this version, the agent will be released and available for all devices.
Posted Jul 31, 2025 - 18:04 EDT

Identified

We are still investigating the issue and working on a potential resolution with an updated version of the AutoElevate agent. If you have opened a ticket with the support team, instructions to access the new version have been sent to you. If you would like to test the latest version of the agent, please contact us at support@cyberfox.com. Once we confirm the resolution with this version, the agent will be updated on all devices.
Posted Jul 25, 2025 - 11:44 EDT

Update

We are still investigating the issue and working on a potential resolution. Thank you for your patience.
Posted Jul 23, 2025 - 09:51 EDT

Update

We are still investigating the issue and working on a potential resolution. Thank you for your patience.
Posted Jul 22, 2025 - 08:46 EDT

Investigating

We are aware of an issue causing system instability, specifically computers locking up or freezing, particularly when waking from hibernation. This issue appears to be related to a Windows update released in early July and affects systems with the Blocker feature enabled in AutoElevate. We recommend temporarily disabling the Blocker feature or rolling back the following Windows updates: KB5058499, KB5063060, KB5060842, KB5060829, KB5062553, and KB5054979. We are actively investigating and monitoring the situation. For more information, please visit our FAQ: https://support.cyberfox.com/494146-faq/computers-locking-up-or-freezing-especially-when-coming-out-of-hibernation
Posted Jul 18, 2025 - 17:07 EDT
This incident affected: AutoElevate (Agent Services).