Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2025 - 17:00 EST
Scheduled
Scheduled Maintenance – PasswordBoss Version Update Date & Time: December 11, 2025, at 5:00 PM EST (Tampa, UTC-5)
We will be performing scheduled maintenance to deploy the latest version of PasswordBoss. This update introduces new features, performance improvements, and important fixes to enhance your experience.
What to Expect:
* The deployment will take approximately 4–6 hours. * During this time, you may experience brief, intermittent interruptions, but the service will remain available. * Once the update is complete, you’ll have access to all the newest enhancements.
Thank you for your patience and understanding as we work to improve your experience.
Posted Dec 09, 2025 - 15:05 EST
This scheduled maintenance affected: Password Boss (Cloud Services, Password Boss Portal, Password Boss Partner Portal, Mobile Apps, Desktop Clients, Browser Extensions).