[PasswordBoss] WebApp Issue

Incident Report for CyberFOX

Resolved

An update has been deployed that should resolve this issue.
Posted Jun 30, 2025 - 20:33 EDT

Monitoring

The issue affecting accounts has been resolved with a temporary patch, and systems are currently stable.

A permanent solution is in development, and progress is being actively monitored.

> In the meantime, please avoid using the recycle bin recovery feature for secure items.

A further update will be shared once the permanent fix is deployed.
Posted Jun 24, 2025 - 19:42 EDT

Identified

We identified another issue after we deployed a fix in the previous incident (https://status.cyberfox.com/incidents/rwzy92rss5fh)

We apologize for any inconvenience this may cause and assure you that our team is working diligently to minimize the impact on your user experience.
Posted Jun 24, 2025 - 18:00 EDT
This incident affected: Password Boss (Cloud Services, Password Boss Portal, Password Boss Partner Portal, Mobile Apps, Desktop Clients, Browser Extensions).