Password Boss WebApp Windows Helper

Incident Report for CyberFOX

Resolved

The issue with the Password Boss Webapp Windows Helper has been resolved. Users should update to the latest version 1.2.0 by using the Menu > Get Apps.
Posted Jun 15, 2026 - 15:51 EDT

Investigating

We are investigating an issue with the Password Boss WebApp Windows Helper.
Posted Jun 15, 2026 - 12:35 EDT
This incident affected: Password Boss (Desktop Clients).