Firefox Browser Extension Issue
Incident Report for CyberFOX
Resolved
We're happy to announce that our extension has been officially approved by the Mozilla team and is now available for use in Firefox!
To access it, please visit: https://addons.mozilla.org/en-US/firefox/addon/password-boss
This new release includes minor improvements. Thank you for your patience during the approval process, and we appreciate your understanding.
Posted Jul 31, 2024 - 10:32 EDT
Update
Our Firefox extension has been officially approved by Mozilla, and we're now working on getting it live in the Firefox Browser Add-ons Store. For those using the current version, the update should be available.
Posted Jul 30, 2024 - 13:34 EDT
Update
We are working on a resolution with the Mozilla team and are awaiting their feedback on how to resolve the issue with the Firefox extension.
Posted Jul 17, 2024 - 12:43 EDT
Update
We are working on a resolution with the Mozilla team and are awaiting their feedback on how to resolve the issue with the Firefox extension.
Posted Jul 11, 2024 - 10:09 EDT
Identified
We have identified the issue and been in contact with the Mozilla team to address the issue with the extension. We are currently awaiting on the Mozilla team to accept the new extension which includes the sources of the files required for review.
Posted Jun 27, 2024 - 09:54 EDT
Investigating
We are currently investigating an issue which is preventing the PasswordBoss for Firefox browser extension from being installed and being automatically disabled if it is already installed.
Posted Jun 25, 2024 - 15:47 EDT
This incident affected: Password Boss (Browser Extensions).