[PasswordBoss] API Performance Issue

Incident Report for CyberFOX

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 08:34 EDT

Investigating

We are investigating API calls within PasswordBoss that are experiencing slowness. Thank you for your understanding and we'll do our best to get this resolved. If you have any questions or concerns, please don't hesitate to reach out to our support team.
Posted Jun 02, 2025 - 17:40 EDT
This incident affected: Password Boss (Cloud Services, Password Boss Portal, Password Boss Partner Portal).