AWS/Heroku Outage

Incident Report for CyberFOX

Resolved

AWS has resolved an incident that caused increased error rates and latency for several AWS services. This issue impacted some CyberFOX services that rely on AWS infrastructure, including scaling of services, analytics, and reporting functions. All CyberFOX services are now fully operational. A small backlog of non-critical data is still being processed, but no further customer impact is expected.

Thank you for your patience while AWS worked to restore service. We will continue monitoring and share any relevant updates if needed.
Posted Oct 20, 2025 - 19:06 EDT

Update

As of 4:52 PM EDT, AWS has continued to reduce throttling for EC2 instance launches in the US-EAST-1 Region. We are seeing steady progress toward pre-incident levels across all Availability Zones (AZs). This improvement has allowed our services to resume normal operations and scale appropriately.

All previously backlogged queues have been cleared, and we anticipate a full return to normal service as AWS expects to resolve the incident within the next two hours. We will continue to monitor updates from our upstream providers and our services closely.
Posted Oct 20, 2025 - 17:38 EDT

Update

AWS is still experiencing an outage affecting the scalability of our services. Recovery is underway with early signs of improvement in some zones. Heroku is also impacted by the AWS outage and has paused automated remediation while it monitors recovery.

Our services are still intermittently affected due to these upstream outages. We are actively working to mitigate any impact and will keep you informed as more details become available. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 13:57 EDT

Monitoring

AWS is currently experiencing a service outage impacting multiple regions. This may affect connectivity, application performance, and the availability of services hosted on AWS infrastructure. The AWS Health Dashboard confirms active issues, and their engineering teams are working to resolve them. We will continue to monitor the situation and provide updates as they become available. You can follow AWS updates directly via the AWS Health Dashboard. (https://health.aws.amazon.com/health/status)

Heroku is also experiencing a multi-cloud service disruption due to a DNS-related issue from a third-party cloud provider. This is affecting Apps, Data Services, & Tools, including AutoElevate. Autoelevate agents will continue to operate with the existing rulesets, but new requests will be disrupted until the Heroku service is restored. A fix has been implemented and is showing positive results, but Heroku’s team is still actively monitoring the situation. For real-time updates, visit the Heroku Status Page. (https://status.salesforce.com/products/Heroku)

Impact on Our Services
Some of our services may be intermittently affected due to these upstream outages. We are actively working to mitigate any impact and will keep you informed as more details become available. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 10:53 EDT
This incident affected: Password Boss (Cloud Services, Password Boss Portal, Password Boss Partner Portal) and AutoElevate (Admin Portal, Mobile Apps).